Fanaleds 2.4g+ occasional hangs on Win10 64bit

Have you found a bug? Please report it here.
demetri
Posts: 4
Joined: 06 Dec 2016, 18:32

Re: Fanaleds 2.4g+ occasional hangs on Win10 64bit

Postby demetri » 03 Aug 2017, 19:35

I had problems with Fanaleds getting stuck and not updating rev lights or current gear and having a non-responsive UI for a couple of days while fanaleds.com web site was down. It looked like Fanaleds app was trying to connect to the web-server and fetch or post something but since the server was not responding it got stuck until being bailed out after a time-out. When that happened I would open TCPView tool from SysInternals package, find the connection that Fanaleds app had established to fanaleds.com and force closed it. After doing that Fanaldes UI and revlights/gear updates would unfreeze and work until it tried to re-connect the the server again in a few minutes.

What finally helped me was adding fanaleds.com 127.0.0.1 line into hosts file. That way it is not be able to connect to the web-server at all and this immediate connection refusal is apparently handled properly by the app and it won't freeze anymore.

Looks like this web-server communication might be going from the thread that is also responsible for UI and revlights update, so if that gets stuck the whole app is stuck too

P.S. I'm using the latest 2.4m version

User avatar
PatrickB
Posts: 14
Joined: 02 Sep 2016, 11:23

Re: Fanaleds 2.4g+ occasional hangs on Win10 64bit

Postby PatrickB » 05 Aug 2017, 14:10

same freezing Problem here
Intel® Core™ i7-4790 // Kingston HyperX DIMM 16 GB DDR3-1866 Kit // Gainward Phoenix GTX 1080 GS
// Thrustmaster T300 // FiTech Momo 27C -SLI Pro // Fanatec Pedals v3

User avatar
Bose321
Fanaleds developer
Posts: 1098
Joined: 18 Jul 2012, 17:00
Location: The Netherlands
Contact:

Re: Fanaleds 2.4g+ occasional hangs on Win10 64bit

Postby Bose321 » 06 Aug 2017, 21:25

How about a slightly older version, same thing?
Fanaleds. Enhance your racing experience. Personal portfolio.

User avatar
PatrickB
Posts: 14
Joined: 02 Sep 2016, 11:23

Re: Fanaleds 2.4g+ occasional hangs on Win10 64bit

Postby PatrickB » 08 Aug 2017, 16:43

Bose321 wrote:
06 Aug 2017, 21:25
How about a slightly older version, same thing?
tried all versions.. still the same
Intel® Core™ i7-4790 // Kingston HyperX DIMM 16 GB DDR3-1866 Kit // Gainward Phoenix GTX 1080 GS
// Thrustmaster T300 // FiTech Momo 27C -SLI Pro // Fanatec Pedals v3

BARMotorsport
Posts: 52
Joined: 17 Jun 2013, 15:52

Re: Fanaleds 2.4g+ occasional hangs on Win10 64bit

Postby BARMotorsport » 28 Apr 2018, 20:32

So whatever happened with this?
I have (and asked for help with the same thing on Win 7 64bit)
Was hoping that 25b would take care of it but no.
Sooo...? There will be no fix for this?


Who is online

Users browsing this forum: No registered users and 1 guest

cron