2.2e Fanaleds hardware settings not saving

Have you found a bug? Please report it here.
User avatar
f1maniac2008
Beta tester
Posts: 14
Joined: 21 Jul 2014, 19:53

Re: 2.2e Fanaleds hardware settings not saving

Postby f1maniac2008 » 26 Sep 2014, 18:10

I deleted the global.xml and tried to disable the SimInstruments Dash again.
It worked for now (no restart of fanaleds or PC)
<global>
<devices>
<device disabled="false" clock="false" revledtype="0" brightness="150" type="910" serial="RAWID-0eb7-038e">
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="0" type="7" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="99" type="2" />
<function index="99" type="3" />
<function index="99" type="1" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="0" type="10" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="99" type="2" />
<function index="99" type="3" />
<function index="99" type="1" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="0" type="63" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="99" type="2" />
<function index="99" type="3" />
<function index="99" type="1" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="0" type="24" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="99" type="2" />
<function index="99" type="3" />
<function index="99" type="1" />
</profile>
<ledlight index="10" value="32768" />
</device>
<device disabled="false" clock="false" revledtype="0" brightness="150" type="6201" serial="">
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="99" type="3" />
</profile>
</device>
<device disabled="true" clock="true" revledtype="0" brightness="150" type="1732" serial="85332313935351416142">
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="99" type="6" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="0" type="22" />
<function index="3" type="10" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="3">
<function index="6" type="32" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="4" />
<ledlight index="0" value="8" />
<ledlight index="1" value="2099332" />
<ledlight index="2" value="1081344" />
<ledlight index="3" value="2" />
<ledlight index="5" value="512" />
<ledlight index="6" value="1" />
<ledlight index="8" value="1024" />
<ledlight index="9" value="1" />
<ledlight index="10" value="128" />
<ledlight index="11" value="2" />
<ledlight index="12" value="1" />
</device>
</devices>
<settings version="1" />
</global>




When I restarted fanaleds - it began from the start
The dash was activated again and I had to disable it again.
Global.xml looks like this

<global>
<devices>
<device disabled="false" clock="false" revledtype="0" brightness="150" type="910" serial="RAWID-0eb7-038e">
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="0" type="7" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="99" type="2" />
<function index="99" type="3" />
<function index="99" type="1" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="0" type="10" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="99" type="2" />
<function index="99" type="3" />
<function index="99" type="1" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="0" type="63" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="99" type="2" />
<function index="99" type="3" />
<function index="99" type="1" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="0" type="24" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="99" type="2" />
<function index="99" type="3" />
<function index="99" type="1" />
</profile>
<ledlight index="10" value="32768" />
</device>
<device disabled="false" clock="false" revledtype="0" brightness="150" type="6201" serial="">
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="99" type="3" />
</profile>
</device>
<device disabled="true" clock="true" revledtype="0" brightness="150" type="1732" serial="85332313935351416142">
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="99" type="6" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="0" type="22" />
<function index="3" type="10" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="3">
<function index="6" type="32" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="4" />
<ledlight index="0" value="8" />
<ledlight index="1" value="2099332" />
<ledlight index="2" value="1081344" />
<ledlight index="3" value="2" />
<ledlight index="5" value="512" />
<ledlight index="6" value="1" />
<ledlight index="8" value="1024" />
<ledlight index="9" value="1" />
<ledlight index="10" value="128" />
<ledlight index="11" value="2" />
<ledlight index="12" value="1" />
</device>
<device disabled="false" clock="false" revledtype="0" brightness="150" type="6201" serial="">
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="99" type="3" />
</profile>
</device>
<device disabled="true" clock="true" revledtype="0" brightness="150" type="1732" serial="85332313935351416142">
<profile joy="" joyname="" type="0" index="0" value="0" offset="0">
<function index="99" type="6" />
<function index="99" type="4" />
<function index="99" type="5" />
<function index="0" type="22" />
<function index="3" type="10" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="3">
<function index="6" type="32" />
</profile>
<profile joy="" joyname="" type="0" index="0" value="0" offset="4" />
<ledlight index="0" value="8" />
<ledlight index="1" value="2099332" />
<ledlight index="2" value="1081344" />
<ledlight index="3" value="2" />
<ledlight index="5" value="512" />
<ledlight index="6" value="1" />
<ledlight index="8" value="1024" />
<ledlight index="9" value="1" />
<ledlight index="10" value="128" />
<ledlight index="11" value="2" />
<ledlight index="12" value="1" />
</device>
</devices>
<settings version="1" />
</global>


The Logfile shows up like this:
0: Log opened with debug level: 4
0: Log opened with debug level: 4
2: Setting up hardware
2: Beginning device enumeration
2: Error reading serial
2: Hardware found on ID: 0 name: ClubSport Wheel vendor: Fanatec ver: 12.22 ser: RAWID-0eb7-038e
3: Found device match in config from serial: RAWID-0eb7-038e
2: Hardware found on ID: 1 name: Clubsport Pedals vendor: Fanatec ver: 0.0 ser:
0: Failed reading main device data
2: Hardware found on ID: 2 name: Dash 1.4 vendor: Siminstruments Pty Ltd ver: 0.3 ser: 85332313935351416142
2: Hardware found on ID: 3 name: Dash 1.4 vendor: Siminstruments Pty Ltd ver: 0.3 ser: 85332313935351416142
0: Failed reading main device data
2: Finished enumeration devices
2: Showing init routine
2: Hardware ready to go
0: Autoupdater: Running latest available version.

+: After I deactivated the SimInstruments Dash again these lines are showing up in the logfile:
0: Failed reading device data
0: Failed reading device data
Last edited by f1maniac2008 on 26 Sep 2014, 18:17, edited 2 times in total.

User avatar
DirkT
Fanaleds developer
Posts: 471
Joined: 18 Jul 2012, 23:29

Re: 2.2e Fanaleds hardware settings not saving

Postby DirkT » 29 Sep 2014, 20:01

can't figure out yet why the device is being stored multiple times. But thanks for all the info so far, hopefully I'll get this fixed someday. Spare time is kind of limited lately...

User avatar
f1maniac2008
Beta tester
Posts: 14
Joined: 21 Jul 2014, 19:53

Re: 2.2e Fanaleds hardware settings not saving

Postby f1maniac2008 » 06 Oct 2014, 20:51

can I somehow disable it completely? (like a blacklist or something)?

Vale79
Posts: 3
Joined: 20 Oct 2014, 01:25

Re: 2.2e Fanaleds hardware settings not saving

Postby Vale79 » 20 Oct 2014, 01:35

Hello I too have the same problem with iRacing . I have a g27 and sli -pro and configured it , the next reboot does not keep the settings . How can I fix?

kippintranet
Posts: 2
Joined: 23 May 2014, 23:06

Re: 2.2e Fanaleds hardware settings not saving

Postby kippintranet » 23 Oct 2014, 21:01

Need to chime in. I have the same issues. At start-up I must manually go to the hardware tab and select to disable the output for the Siminstruments Dash. I tried modifying the global.xml and disable the device but it still does not work.

Nimzovich
Posts: 14
Joined: 26 Apr 2014, 23:32

Re: 2.2e Fanaleds hardware settings not saving

Postby Nimzovich » 27 Oct 2014, 03:40

I'm having the same problem with 2.2f.

Raptor
Posts: 2
Joined: 25 Oct 2014, 04:57

Re: 2.2e Fanaleds hardware settings not saving

Postby Raptor » 28 Oct 2014, 03:54

Same issue as others, even rolled back to a previous build and no luck. However I do not have a Sim Instruments Dash.

Please fix. :oops:

Thanks for the amazing product.
Last edited by Raptor on 28 Oct 2014, 03:55, edited 1 time in total.

User avatar
DirkT
Fanaleds developer
Posts: 471
Joined: 18 Jul 2012, 23:29

Re: 2.2e Fanaleds hardware settings not saving

Postby DirkT » 28 Oct 2014, 11:32

This seems to be fixed in the current Beta, but we're tackling some other issues before we want to release this, so please bare with us.

Vale79
Posts: 3
Joined: 20 Oct 2014, 01:25

Re: 2.2e Fanaleds hardware settings not saving

Postby Vale79 » 28 Oct 2014, 13:21

ok thanks we wait impatiently :mrgreen:

User avatar
Bose321
Fanaleds developer
Posts: 1133
Joined: 18 Jul 2012, 17:00
Location: The Netherlands
Contact:

Re: 2.2e Fanaleds hardware settings not saving

Postby Bose321 » 28 Oct 2014, 15:55

The new version is now live.

Please remove your global.xml file before updating to make sure it's working afterwards.
Last edited by DirkT on 28 Oct 2014, 16:15, edited 2 times in total.
Fanaleds. Enhance your racing experience. Personal portfolio.


Who is online

Users browsing this forum: No registered users and 1 guest